cancel
Showing results for 
Search instead for 
Did you mean: 

What requirements must my smartphone meet in order to use the BMW Connected App?

What requirements must my smartphone meet in order to use the BMW Connected App?

iOS at least version 9.3. Android at least version 5.0. Please make sure that your mobile device is able to download the required software version. More information can be provided by the respective manufacturer.
Was this answer helpful?